.htaccess hotlink protection y ya parece que esta el tema solucionado

Pues nada señores del público, llevo desde las 9 de la mañana repasando el tema del blog y parece que tras darle 1200 vueltas al tema lo he consegido solucionar… y ya no canto victoria, a ver por si le pasará a alguién explico el tema desde el principio.

Ayer activo hotlink protection, se va todo al traste y cuando lo desactivo todo menos el blog funciona, el problema es que si no toco nada mas, solo carga la página principal y el resto de páginas no las carga pero la principal la carga correctamente.

Salgo a patearme internet y encuentro bastante info, bueno, mejor dicho, encuentro a bastante gente con el mismo problema pero no encuentro soluciones (ese es uno de los motivos por los que me meti a hacer este blog) bueno resumiendo, anoche consegui dejar accesible el blog sin afectar al resto de páginas de mis clientes pero esta mañana sorpresa, las imágenes no se cargan y otra vez vuelta a buscar soluciones…

Mirando y requetemirando encuentro unos archivos muy simpáticos llamados “.htaccess” procedentes del planeta Linux y mi mente se pone a buscar en el baúl de los recuerdos y recuerdando recordando recuerdo que estos archivos tienen cosas dentro en plan temas de accesos y demás… busco por internet y confirmo lo que me sospechaba, en estos ficheros esta la configuración de Hotlink, así que tras un rato de investigación me lio la manta a la cabeza, y como no soy capaz de hacer las cosas bien me saco una chapuza de la manga, en el archivo observo un fragmento que viene a ser.

(jpegjpggifbmp)


Vale pues muy bien, estos son exactamente los archivos a los que mi pobre blog no puede acceder. Antes de seguir comento, el archivo culpable (es decir, el .htaccess maldito) se encuentra en el raiz del blog, si el blog estuviera en:

c:Mis websmiblog

el archivo esta ubicado en:

c:Mis websmiblog.htaccess

Esto lo aclaro que lo mismo entra alguién que no sabe que es eso del raiz… bueno prosigo.
En un alarde de inteligencia (atificial se podría decir) cambio el fragmento

(jpegjpggifbmp)

Que esta repetido tres veces (no sé si porque es por los permisos de linux que van por ahí los tiros) y pongo lo siguiente.

(raravi)

jejejej, ya lo habeis pillado no, pues si, las imágenes se ven de lujo y durante media hora todo se queda así, pero mi cerebro de repente decide pensar un poco y me dice en voz bajita.

cerebro: Pse pse, Pablo, tio comprueba que has restringido los ficheros avi y rar y esos estan para descargar desde tu página y lo mismo… no descargas ni tu
Pablo: Pues… voy a ver

Y eso es lo que estaba pasando, que no se pueden descargar así que como no sé si puedo dejar el listado de “archivos restringidos” en blanco he cambiado y he puesto dos extensiones que no voy a usar y ya parece funcionar todo.

De todas formas, el primo lo revisará todo y ya seguro que lo deja perfecto sin tanta chapuza.

Saludos, espero que ayude a alguién todo esto que he contado que me ha sacao de mis casillas!!

Y como siempre digo, a base de golpes, se aprende.

Sin categoría

Deja una respuesta